
 

 

 

 

Pcounter CGI Utilities  
Installation and Configuration 

For Pcounter for Windows version 2.55 and above 

 

About this document 
 
The core Pcounter application contains a number of CGI extension applications which can 
be configured using IIS. This document details the installation and configuration of these 
applications. These applications are: 
 

 Webclient.exe for web release of print jobs 
 Account.exe for web balance transactions 
 Balance.exe for online checking of a user’s Pcounter balance 
 PcounterReporting.exe for online reports 

 
All of the discussed executable files are stored in (default location) C:\Program 

Files\Pcounter for NT\NT 
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1. IIS Installation and Configuration 
 

Microsoft Internet Information Services must be installed and configured on the Pcounter 
Data server.  
 
1.1 IIS6 / WINDOWS SERVER 2003 INSTALLATION AND SETUP 
 
IIS6 is included with Windows Server 2003. If IIS is not installed on your Pcounter 
server it can be installed through Control Panel > Add/Remove Programs > 
Add/Remove Windows Components.  
 
Select Application Server > Details. Check Internet Information Services and click 
OK followed by Next on the previous window. IIS components will now install. Please 
note: a server reboot may be necessary once installation is complete. 
 

 
Once complete, create a new directory named cgi-bin within the IIS directory 
C:\inetpub\wwwroot. 
 
Open IIS Manager (under Administrative Tools). Using the directory structure in the 
left-hand frame browse to [ServerName]\Web Sites\Default Web Site. Right-click 
Default Website and select New > Virtual Directory. When prompted for an Alias 
enter cgi-bin and click Next. Enter or browse to the path C:\inetpub\wwwroot\cgi-
bin when prompted and click Next. 
 

 



Set the Virtual Directory Access 
Permissions to Read, Run scripts and 
Execute and click Next to finish the wizard. 
 

Copy the relevant exe file from C:\Program 
Files\Pcounter for NT\NT into the ~\cgi-bin 
directory and refresh IIS Manager. The file will 
appear in the virtual directory you have just 
created. Right-click the file and select 
Properties. 
 
Click the File tab followed by the Edit button 
under Authentication and Access Control.  
 

 
Uncheck the option for Enable anonymous 
access. 

 
Ensure the Basic authentication and 
Integrated Windows authentication 
options are selected from the list of 
authentication methods. Click Yes when 
advised of the security implications. 
 
Type in, or hit Select and browse to, the 
name of your domain. 
 
Click OK then OK and restart the default 
website by selecting it from the directory 
structure and hitting Stop then Play on the 
IIS toolbar. 
 
 
Now see the relevant section for the CGI app 
you wish to use section 2 for the Universal 
Configuration Options. 
 

 
1.2 IIS7 / WINDOWS SERVER 2008 INSTALLATION AND SETUP 
 
On Windows Server 2008 IIS is added as a Server Role through Server Manager. To 
install this, open the Server Manager and Add the Role Web Services (IIS). Ensure 
that the default services are installed as well as the following: 
 

 Security > Basic Authentication 
 Security > Windows Authentication 
 IIS 6 Management Compatibility > [ALL] 
 Application Development > CGI 

 
A reboot of the server may be necessary after this. 

 
Once IIS is installed, create the folder cgi-bin in the IIS directory 
C:\inetpub\wwwroot\. 
 
Open IIS Manager from Administrative Tools and browse to [server 
name]\Sites\Default Website. Right-click Default Website and Add a Virtual 



Directory. Set the Alias to cgi-bin and for the Physical Path browse to the folder 
~\cgi-bin you just created. Click OK. 
 
In IIS Manager, highlight the cgi-bin directory and select Features View and 

Authentication from the IIS options.  
 

 
Right-click Basic Authentication and select Enable. Right-click again and select Edit. 
Enter your domain (NetBIOS name only necessary) into the subsequent popup and click 
OK. Ensure the other authentication methods are Disabled. 
 
Select the Default web site again and Stop / Start it using the controls on the right. 
 
Now see the relevant section for the CGI app you wish to use and section 2 for the 
Universal Configuration Options. 
 

2. Universal Configuration Options 
 

Once IIS is installed on the server copy the relevant CGI executable (for instance 
WebClient.exe) from C:\Program Files\Pcounter for NT\NT into 
C:\inetpub\wwwroot\cgi-bin\ 
 
2.1 IISScript SETUP 
 
Each Pcounter CGI app is configured using this 
window. See the relevant section for each 
application on instructions on how to access 
this window (method varies depending on app).  
 
The URL for the application can be changed by 
editing the text box Virtual directory name. 

 
If you have set the application up on a website 
other than the existing Default website set 
this in the web site drop-down box. Ensure 
that you have both Use basic authentication 
and Use IE Integrated Authentication 
checked and hit Install.  



A command window will load and process the necessary instructions. Once completed it 
will read Script complete. 
 
The file [application].ini will have been created in the cgi-bin directory containing all 

preference settings. 
 
You will now be able to browse to the URL at the top of the application. 
 
2.2 CONTROLLING ACCESS 
 
There are no facilities with the applications themselves to restrict access. Access should 
be restricted using Windows files permissions to the [application].exe file. 
 
It is recommended to Deny Access to the All Users group, create a custom “Pcounter 
[Application] Access” group and grant access to this group. 
 

3. Webclient 
 
Pcounter Webclient is a utility application which allows users to log onto a webpage to 
release print jobs. This acts as a secure release mechanism and provides print 
confirmation. It can also be configured to allow a user to release jobs printed by other 
users, known as the Teacher Release configuration (see 3.4.1). It can also be used as 
a replacement for Pcounter Popup if this is not working for whatever reason. 

 
3.1 CONFIGURING WEBCLIENT 
 
Once the file Webclient.exe has been configured through IIS in the method described in 
1.1 or 1.2, double-click the file to run the application.  

 
You can edit the title of the 
webpage by changing 
Window Title. 
 
There are a number of 
different Window Types 
offering different features. 
These are explored in 

Appendix A. The simplest 
of these is Job Validation 
which simply asks for 
confirmation before 
printing. Each has its own 
set of options, which is 

also explored in the same 
Appendix. 
 
Message text allows you to 
customise the message the 
user will see on the release 
page. You have use of the 

following substitutions: 
 

 Username %U 
 Balance %B 
 Document %D 
 Page count %P 

 



Printer List allows you to specify which printers are monitored by the Webclient. 
Please note: You will also need to configure the printer itself for use with the Webclient. 

 
When the settings above are configured as desired hit Run IIS configuration script to 

load the window described in 2.1. 
 

3.2 CONFIGURING PRINT QUEUES FOR WEBCLIENT 

All printers that are to be monitored by Pcounter Webclient require a few settings 

changes. To do this, open the local configuration of the printer in Pcontrol (right-click the 
printer > Pcounter > Configuration).  

 
Check the box Enable 
popup, print release etc… 
This will automatically 
activate the following 

options: 
 

 Count jobs in 
advance for display 

 Pause all jobs will be 
set to Super Pause 
 

Click OK and confirm when 
prompted to restart the 
Pcounter Printer Control 
Service 
 

 
3.3 WEBCLIENT USAGE 
 
PcounterWebclient in its most basic format (Job Validation) looks like: 

 
It will display, for the logged in user: 

 
 Every document they have waiting (Document) 
 The printer the job was printed to (Printer) 
 The page count of that job (Pages) 
 Total cost of the job if applicable (Cost) 

 
Jobs can be printed or deleted by checking the associated checkbox and pressing the 

relevant button. 
 
Preferences loads the adjacent popup which allows 
the end user to configure various personal settings. 
 



Document and Client code list heights specify how many pixels of the screen is 
dedicated to these lists before requiring vertical a scroll bar. 
 
Documents are waiting – Restore window and No documents are waiting – 

Minimize window allows the webpage to operate in the same manner as Pcounter 
Popup. Provided the window itself is left open, when jobs are waiting to print the 
window will maximise itself and when there are no jobs it will minimise, waiting on the 
taskbar. Please note: This feature is only compatible with Internet Explorer. 
 
3.4 OPTIONAL SETTINGS 
 
3.4.1 “TEACHER RELEASE” 
 
Webclient can be configured to show all waiting print jobs to the logged in user, 
regardless of the owner of the job. The logged in user can release the jobs for other 
users and if necessary select a Client Code. 
 

This configuration can be used to allow an authority figure to authorise print jobs for 
other users, such as a teacher authorising a students’ prints. 
 
To enable Teacher Release mode, make the following additions in 
C:\Inetpub\wwwrott\cgi-bin\webclient.ini once Webclient has been installed as already 
described: 
 
Under the heading [Settings] (create this heading if it does not exist) add 
 

 DisplayAllJobs=2 
 DisableJobOwnerChange=1 

 
The username of the job owner will now be displayed in [] 
in the Document column along with the document name. 
When printed the job will still be logged by the user who 
initially printed the job rather than who released it. 

 
Please note: If configuring for Teacher Release mode please remember to restrict 
access to the webpage through AD/NDS permissions (see 2.2) 
 

3.4.2 MULTIPLE WEBCLIENTS 
 
It is possible to configure multiple Webclient pages to run simultaneously, each with a 
different URL. The advantage of this is that you can restrict each different webpage to 
certain printers, therefore restricting which printers certain users can print to and release 
from. This configuration is also commonly used in conjunction with the Teacher Release 
mode to restrict each webpage to a specific printer, so each classroom or subject has a 

different release page. 
 
To configure for multiple Webclients, simply:  
 

 Place as many copies of Webclient.exe into C:\inetpub\wwwroot\cgi-bin\ and 
configure as described above in 3.1 and 3.2. 

 Restrict each Webclient.exe to the desired list of printers 
 Change the Virtual Directory Name during the installation to the desired name 

 
Please note: If using in conjunction with Teacher Release remember that you will now 
have multiple copies of Webclient.ini which will need altering as per 3.4.1. 
 
 



4. ACCOUNT.EXE for Balance Transactions 
 
Account.exe is an accounting application which allows none-technical members of staff to 
edit users’ balances without the need to give them access Pcounter Administrator. 

 
4.1 CONFIGURING ACCOUNT.EXE 
 
Ensure that file ACCOUNT.EXE has been copied into the cgi-bin directory and been 
configured in the manner described in 1.1 or 1.2. 
 
Browse to the cgi-bin directory at a command line and type the command: 
 
ACCOUNT IISCFG 

 
This will load the window described in 2.1. See this section for details.  
 
4.2 USING ACCOUNT 
 
The URL will prompt for authentication then load the following page: 

  

Enter the username of the user’s balance you wish to edit into the Login name: control. 
Pressing the £ will query the user’s current balance and return their full name from AD. 
This is useful to confirm that the correct username has been 
entered. 
 
The Action drop down box contains a choice of these options 

to perform on the currently selected user. 
 
Please note: for full descriptions of these transactions see 
Pcounter Administrator End User Guide. Full descriptions of 
these transactions are outside the scope of this document. 
 
Enter the value in pounds into the Amount control. The 

format is pounds and pence so 1.00 = £1.00. 
 
Comment is optional, allowing you to enter a 
description of the transaction, for example Refund. This 
will be recorded in the Document field in the Pcounter log. 
 

http://www.altman.co.uk/files/padminenduserguide.pdf


Reset clears the form, whilst Submit will perform the current transaction and report 
back once complete: 

 
Please note: In order to use Account the user must have write access to the 
Pcounter Balance Database, default filepath C:\PCOUNTER\DATA\[DOMAIN-
NAME].DBF.  

 

If the user does not have sufficient rights to this file they will receive an Access Denied 
[5] error when trying to edit a balance. 
 

5. Balance.exe for self-checking of a user’s balance 

 
Balance.exe allows a user to check their own Pcounter balance via a webpage. 
 
5.1 CONFIGURING BALANCE 
 
Ensure that file BALANCE.EXE has been copied into the cgi-bin directory and been 
configured in the manner described 1.1 or 1.2. 
 

Browse to the cgi-bin directory at a command line and type the command: 
 
BALANCE /IISCFG 

 
This will load the window described in 2.1. See this section for further details. 
 
5.2 USING BALANCE 

 
The URL will prompt for authentication then load the following page: 

 
 
  



6. Pcounter Web Reporting 
 
Pcounter Web Reporting allows authorised users to produce Pcounter reports over the 
web without the need to grant them access to Pcounter Administrator.  

 
Please note: This application is different to the additional reporting module Pcounter 
Web Reports. For more information on this product and the additional features it offers 
(such as automated scheduled reports) and to download a free 60 day trial see 
http://www.altman.co.uk/downloads/print-copy-management. 
 
6.1 CONFIGURING PCOUNTER WEB REPORTING 
 
Ensure that file PcounterReporting.exe has been copied into the cgi-bin directory and 
been configured in the manner described 1.1 or 1.2. 
 
Double-click the file to run the configuration and load the window described in 2.1. See 
this section for further details. 

 
6.2 USING PCOUNTER WEB REPORTING 
 
The URL will prompt for authentication then load the following page: 

 

http://www.altman.co.uk/downloads/print-copy-management


Choose the desired report using the menu in the left frame then the controls in the 
middle of the page. 
 
Clicking Generate will produce the report: 

 
Please note: An explanation of each individual reporting option is outside the scope of 
this document. For a full and detailed guide on Pcounter Reports please see the 
Pcounter Administrator Reports Generator User Manual. 
  

http://www.altman.co.uk/files/pcounterforwindowsreportgeneratorusermanual.pdf


Appendix A: Web Client Window Types 

 
This Appendix will briefly explore the features of the different Window Types of 

Webclient. Each Webclient Window Type is modelled on a Pcounter Popup Window 
Type and consequently more detailed discussions can be found in the Pcounter Popup, 
Client Codes and Pcounter Users’ Manual, section A. 

 
1. CLIENT CODE LIST 

 
Client Code list allows the user to assign a 
Client Code (or Department code) to the 
released print job by selecting it from a pick 
list. Manual free type is also permitted using 
the Enter client code text box. The feature is 
useful when used in conjunction with Teacher 
Release as it allows users in a position of 
authority to select the correct code for other 
users’ prints. 
 
The Webclient Configuration application 
Options tab offers the standard Client Code list 
options that are also available for Pcounter 

Popup Window Type.  
 
2. ENTRY FORM 
 
Entry Form allows only manual type of Client Code. Settings on the Options tab are 
the same as with Client Code list. 
 
3. JOB VALIDATION 
 
Job Validation is the simplest configuration and is simply used to confirm printing. The 
Webclient page simply shows the list of queued jobs. There are no additional settings on 
the Options tab for Job Validation. 
 

4. MATTER NUMBER LIST 
 
The Matter Number list allows for the free type or selection of a 2-tiered client code 
(“sub-code”).  
 
 
 
 
 
 
 
 
 

http://www.altman.co.uk/files/pcounterpopupclientcodesanduserstechnicalmanual.pdf
http://www.altman.co.uk/files/pcounterpopupclientcodesanduserstechnicalmanual.pdf


 
5. EMBEDDED LOGON 
 
Embedded Logon includes a 

Username and Password box on 
the page, which can be used to 
enter the credentials of a 
Pcounter User or of another AD 
User if access to the webpage has been setup with Anonymous Access. 
 
The choice between AD Users and Pcounter Users is set on the Options tab of the 
Webclient Configuration application. 
 
This option is useful in a public access area where users do not have their own AD 
account but you still wish to account for and potentially charge these guest users for 
their printing. 
 

6. JOB ID 
 
Job ID changes the print job owner name for visual identification only. This is intended 
for use with Pcounter Station or for situations where users are sharing login accounts 
and additional information for identifying print jobs is required. 
 
7. AUTOMATIC VALIDATION 
 
With Automatic Validation set all jobs queued will be automatically released when the 
page is loaded. If using Teacher Release mode this will release all jobs for all users, if 
not just the jobs for the logged on user will be released. 
 
 


